No Oil Pressure after overhaul on ym155d

Post your questions or problems you are haviing with your Yanmar tractor here.

Moderator: Aaron

RickG
Volunteer Poster
Posts: 3
Joined: Wed Jun 12, 2019 8:06 pm

No Oil Pressure after overhaul on ym155d

Postby RickG » Wed Jun 12, 2019 8:29 pm

I have had the tractor for about 10 years with no issues, then spun a bearing on the no 1 cylinder. decided it was time to overhaul the motor. I put in new cylinder sleeves, new pistons & connecting rods, new rings, new injectors, new valves & guides (head reworked by machine shop), new oil pump, new connecting rod and main bearings to match reground crankshaft,all new gaskets. Blew out all the oil lines in the block before assembling. Started it after putting it back together. Never got any oil pressure to show on the new oil pressure gauge. shut the tractor off. pull the fitting for the oil gauge, no oil there. pulled the oil filter no oil in the filter. I have overhauled several gas engines and car engines but this is the first tractor. I am at a lost as to what to check. Any help would be appreciated. No answer is wrong. I have around $2,500 in to the parts for the motor, so I am not ready to give up on this yet.

Aaron
Site Administrator
Posts: 2941
Joined: Thu Jul 26, 2007 12:39 pm
Location: Iowa Park, TX

Re: No Oil Pressure after overhaul on ym155d

Postby Aaron » Thu Jun 13, 2019 1:22 pm

I have heard of this before and I think the guy ended up having a bad oring on his pickup tube if I remember correctly. Where the tube seals to the block.

1.jpg
1.jpg (96.36 KiB) Viewed 453 times

RickG
Volunteer Poster
Posts: 3
Joined: Wed Jun 12, 2019 8:06 pm

Re: No Oil Pressure after overhaul on ym155d

Postby RickG » Thu Jun 13, 2019 5:15 pm

That sounds good but the whole tube is submerged in the oil all the way to the block, which to me would mean the oil would still get sucked into the pump.
I didn't see anything in my manuals, but does the new oil pump need to be primed some how?

winston
Volunteer Poster
Posts: 5005
Joined: Mon Feb 01, 2010 7:29 am
Location: North East Texas

Re: No Oil Pressure after overhaul on ym155d

Postby winston » Fri Jun 14, 2019 4:34 am

Don't know how to do it but you might ponder on removing the oil pressure sensor, use the opening to attach some kind of pressured oil introduction that might force oil through the system and into the pump. If it were to work you might have to drain out a little oil. Just a crazy idea but I wouldn't want to run that engine very long without oil pressure. Might need this adapter. https://www.hoyetractor.com/PROD/OGA-1.htm

https://www.summitracing.com/parts/wmr- ... IfEALw_wcB

https://www.ebay.com/itm/Boat-Marine-60 ... 2633452545

RickG
Volunteer Poster
Posts: 3
Joined: Wed Jun 12, 2019 8:06 pm

Re: No Oil Pressure after overhaul on ym155d

Postby RickG » Mon Jun 24, 2019 8:58 pm

I pulled the motor back out and filled the oil pump with oil, put it back in and it worked. I think you need to fill the pump with oil before installing it, so it can prime itself when it is started.

winston
Volunteer Poster
Posts: 5005
Joined: Mon Feb 01, 2010 7:29 am
Location: North East Texas

Re: No Oil Pressure after overhaul on ym155d

Postby winston » Tue Jun 25, 2019 4:20 am

Wow, lot's of work to get oil pumping, but glad your up and running. Thanks for keeping us informed. I will remember this, at least for a day or two. :mrgreen:


Return to “Tech Support”

Who is online

Users browsing this forum: No registered users and 18 guests