YM2000B 3 Pt Hitch Issue

Post your questions or problems you are haviing with your Yanmar tractor here.

Moderator: Aaron

Cardentm
Volunteer Poster
Posts: 6
Joined: Mon Jun 03, 2019 10:21 am

YM2000B 3 Pt Hitch Issue

Postby Cardentm » Mon Jun 03, 2019 10:29 am

Just bought a YM2000B from an individual. It came with a 5ft. finishing mower (King Kutter) and has 1112 hrs on a working hour meter. He had only owned the tractor for 2 months and didn't really use it. It runs great but during the first mow of my field (after full grease job on the mower and tractor) with the unit the 3 pt hitch would not lift once the tractor heated up (ran the mower at 2200 rpm for about 20 mins in thick grass). After some cool down the 3 pt. returned to normal lift and lower function. I've bought new fluid to change the fluid and clean the hydraulic screen filter when I have time.

Question to the forum is what may be the cause of failure to lift issue when fluid is warm?

Also note that the rear axle has some leakage on the left seal. Any diagrams on replacing seal would be helpful also.

Aaron
Site Administrator
Posts: 2964
Joined: Thu Jul 26, 2007 12:39 pm
Location: Iowa Park, TX

Re: YM2000B 3 Pt Hitch Issue

Postby Aaron » Mon Jun 03, 2019 10:51 am

The most common cause would be junk in your oil eventually getting sucked up onto the screen & clogging it. When you shut it off some of that junk falls off and eventually gets sucked back up when you run it again. It could also be that your rubber suction coupler is letting air get sucked in and the oil eventually gets foamy which will not work correctly. If it has tiny cracks or loose clamps it might not leak oil out but can let air in... especially if the filter is clogged.

Cardentm
Volunteer Poster
Posts: 6
Joined: Mon Jun 03, 2019 10:21 am

Re: YM2000B 3 Pt Hitch Issue

Postby Cardentm » Mon Jun 03, 2019 2:28 pm

Thanks for the quick reply. I will try the filter clean and fluid change this weekend. I'm not familiar with the rubber suction coupler. Any diagram help to show where that is would be appreciated.

Aaron
Site Administrator
Posts: 2964
Joined: Thu Jul 26, 2007 12:39 pm
Location: Iowa Park, TX

Re: YM2000B 3 Pt Hitch Issue

Postby Aaron » Mon Jun 03, 2019 2:29 pm


Cardentm
Volunteer Poster
Posts: 6
Joined: Mon Jun 03, 2019 10:21 am

Re: YM2000B 3 Pt Hitch Issue

Postby Cardentm » Sat Jun 08, 2019 8:17 pm

Update: Drained fluid this afternoon and removed the screen filter. It was fully covered with gunk. Cleaned it up with diesel fuel and installed it. Put new fluid in and hydraulics work as they should even after working the tractor for 30 mins. Thanks for the help!


Return to “Tech Support”

Who is online

Users browsing this forum: No registered users and 18 guests