New-to-me YM1500D with some issues and questions

Post your questions or problems you are haviing with your Yanmar tractor here.

Moderator: Aaron

yzrmbsg
Volunteer Poster
Posts: 27
Joined: Wed Jan 23, 2019 7:20 pm
Location: Florence, AZ

Re: New-to-me YM1500D with some issues and questions

Postby yzrmbsg » Sat Mar 02, 2019 9:47 pm

On a positive note, the knuckles were filthy and full of sludge, got them all cleaned up, bearings appear to be in good shape. Just need the right (red) seals and gaskets, then can put her back together!

Got the water temp gauge mounted, haven't been able to test it yet since I still have it up on the Jack stands.

Replaced the 12 balls in the drive shaft (only had 3 of 12), the front diff input shaft is damn near rounded off, so I will likely need to source that from somewhere...biggest problem now is, is there a difference between RED and GREEN diffs? or is it just the knuckles?

Replaced the nasty air filter seals, tighted alot of loose bolts all over the tractor.

Still need to replace the suction hose coupler and one of my hydraulic high pressure connections needs a good cleaning/sealing.

Just a few more things to button up and I can get it doing some work instead of me doing all the work to to it!

yzrmbsg
Volunteer Poster
Posts: 27
Joined: Wed Jan 23, 2019 7:20 pm
Location: Florence, AZ

Re: New-to-me YM1500D with some issues and questions

Postby yzrmbsg » Tue Mar 05, 2019 8:25 am

Forgot to add pictures of the work!

Temp Guage:
Image

4WD Knuckles:
Image
Image
Image
Image
Image
Image

yzrmbsg
Volunteer Poster
Posts: 27
Joined: Wed Jan 23, 2019 7:20 pm
Location: Florence, AZ

Re: New-to-me YM1500D with some issues and questions

Postby yzrmbsg » Mon Mar 11, 2019 12:18 am

yzrmbsg wrote:
Replaced the 12 balls in the drive shaft (only had 3 of 12), the front diff input shaft is damn near rounded off, so I will likely need to source that from somewhere...biggest problem now is, is there a difference between RED and GREEN diffs? or is it just the knuckles?


As I feared, got the knuckles back together this morning, all seems to be sealed up and no leaks.....but about 30 minutes into box blading my driveway.... I lost my driveshaft!!! All 12 new balls....GONE.
Found some of the other pieces, driveshaft, spring, 1 of 2 washers, cotter pin still in place, not sure if I had a coupler seal, but if I did, it's gone, coupler came off the splines and, and all the fresh grease is now full of gravel/sand.

The pinion shaft is toast.

I see that "red" and "green" pinion shafts have different part numbers, neither of which are available to purchase. Says "contact for used"?

With my tractor being a "green" with "red" knuckles....how do I know if I have a "red" or "green" differential so I can get the right pinion shaft?

yzrmbsg
Volunteer Poster
Posts: 27
Joined: Wed Jan 23, 2019 7:20 pm
Location: Florence, AZ

Re: New-to-me YM1500D with some issues and questions

Postby yzrmbsg » Tue Mar 19, 2019 5:32 pm

I suppose this would/could be why my input shaft is torn up?? The 1500d is supposed to have 5-14 tires....mine has 6-14 tires on it.

Image

yzrmbsg
Volunteer Poster
Posts: 27
Joined: Wed Jan 23, 2019 7:20 pm
Location: Florence, AZ

Re: New-to-me YM1500D with some issues and questions

Postby yzrmbsg » Fri Mar 22, 2019 9:46 am

Can anyone confirm my suspicion? Or is the 6-14 within the 2-10% ratio range and nothing to be concerned about?

I have seen a few other 1500D's online also running 6-14's on the front....just in pictures, not sure if they had similar issues as I have.

Aaron
Site Administrator
Posts: 2897
Joined: Thu Jul 26, 2007 12:39 pm
Location: Iowa Park, TX

Re: New-to-me YM1500D with some issues and questions

Postby Aaron » Fri Mar 22, 2019 10:12 am

The 6-14 would absolutely put a lot of stress on the 4wd. For every one rotation of the tires your front tires are trying to go an extra 5" more than the rear tires (assuming the rear tires are correct).

yzrmbsg
Volunteer Poster
Posts: 27
Joined: Wed Jan 23, 2019 7:20 pm
Location: Florence, AZ

Re: New-to-me YM1500D with some issues and questions

Postby yzrmbsg » Fri Mar 22, 2019 4:53 pm

Aaron wrote:The 6-14 would absolutely put a lot of stress on the 4wd. For every one rotation of the tires your front tires are trying to go an extra 5" more than the rear tires (assuming the rear tires are correct).


yes, the rears are correct, this lil tractor sure has been neglected in it's previous life! ugh


Return to “Tech Support”

Who is online

Users browsing this forum: No registered users and 17 guests