Yanmar 1700 runs full throttle

Post your questions or problems you are haviing with your Yanmar tractor here.

Moderator: Aaron

Kspring
Volunteer Poster
Posts: 4
Joined: Fri Feb 12, 2021 11:10 am

Yanmar 1700 runs full throttle

Postby Kspring » Fri Feb 12, 2021 11:22 am

I have a yanmar 1700. I had a no start issue which was traced to bad injection pump. I purchased a new pump from Hoye tractor and installed it. It runs great for about 2 min, the throttle responds great ideas nice and then it goes full throttle. I have looked at hove we and manually moved rack and it is in ideal position and doing what it is supposed to do except it’s still full throttle only way to slow it down is to restrict fuel supply. Anyone have any ideas? Also to shut it down I have to decompression it or shut fuel off.

Aaron
Site Administrator
Posts: 3415
Joined: Thu Jul 26, 2007 12:39 pm
Location: Iowa Park, TX

Re: Yanmar 1700 runs full throttle

Postby Aaron » Fri Feb 12, 2021 11:44 am

That is almost always caused by the rack being sticky or the governor linkage binding. The new pumps are coated in a sticky lube and sometimes need to be cleaned with WD40 or similar until the rack slides just by tipping the pump. Other than those 2 things I can really think of anything that will cause that.

Kspring
Volunteer Poster
Posts: 4
Joined: Fri Feb 12, 2021 11:10 am

Re: Yanmar 1700 runs full throttle

Postby Kspring » Fri Feb 12, 2021 1:11 pm

Thanks for info, I have checked the rack and the linkage and it looks all good. The governor also dose have the rack in the forward or idle position and the throttle lever dose not change anything and it still runs full throttle.

Aaron
Site Administrator
Posts: 3415
Joined: Thu Jul 26, 2007 12:39 pm
Location: Iowa Park, TX

Re: Yanmar 1700 runs full throttle

Postby Aaron » Fri Feb 12, 2021 1:23 pm

The governor also dose have the rack in the forward or idle position and the throttle lever dose not change anything and it still runs full throttle.


Does the pump rack stay in the full idle position when it runs away for sure? The hand throttle position is really just 'requesting' that the governor adjust the engine speed. So, even if the hand throttle does not move at all, there is typically a lot of constant adjustments being made to the fuel rack to maintain a constant speed.

Depending on the engine load, the RPMs can run away even at a very slow rack position. It should not do it at full idle but it could do it at a low idle position if the engine was not under any load.

I'm not really sure what else would/could cause that. You don't have any kind of electric fuel pump added on or anything that might be over fueling the pump? Not sure if that would even do what you are describing though. I guess you are sure you don't have some gasoline in there or anything weird? Really just grasping at straws here though.

Kspring
Volunteer Poster
Posts: 4
Joined: Fri Feb 12, 2021 11:10 am

Re: Yanmar 1700 runs full throttle

Postby Kspring » Fri Feb 12, 2021 1:34 pm

Yes, I have the side cover off and can manipulate the rack manually with fingers and no matter it runs at full rpm. The fuel supply is just factory, gravity feed. Yea I am baffled by this. Can the pump be faulty, is it worth sending back and getting another one and trying?

Aaron
Site Administrator
Posts: 3415
Joined: Thu Jul 26, 2007 12:39 pm
Location: Iowa Park, TX

Re: Yanmar 1700 runs full throttle

Postby Aaron » Fri Feb 12, 2021 2:02 pm

Well... I have finally stopped saying something is 'impossible' but, that being said, I can't really see how the pump could run normally for a while and then all of the sudden start running away with the rack physically held at full idle. I have just never heard of that before. The problem with sending that one back is if our supplier tests it and the pump is good then they will just send it back to you. So I like to be sure there is not something else going on before wasting your time & money shipping stuff around.

Did you replace your fuel with fresh fuel before installing the new pump?

Kspring
Volunteer Poster
Posts: 4
Joined: Fri Feb 12, 2021 11:10 am

Re: Yanmar 1700 runs full throttle

Postby Kspring » Mon Feb 15, 2021 1:07 pm

Hey Aron back at it. Yes I have all new fuel and filters, and flushed lines using new fuel. So today I am looking at the return system and checking on the glow plug circuit and I have found I have no fuel coming out of both injector return ports right on the injectors. I am lost!

Aaron
Site Administrator
Posts: 3415
Joined: Thu Jul 26, 2007 12:39 pm
Location: Iowa Park, TX

Re: Yanmar 1700 runs full throttle

Postby Aaron » Mon Feb 15, 2021 1:17 pm

That is pretty normal. I'm not sure what the exact cause is but we see a lot of injectors that do not return any or very little fuel.


Return to “Tech Support”

Who is online

Users browsing this forum: No registered users and 27 guests