YM 276D stalled following filter and oils changes

Post your questions or problems you are haviing with your Yanmar tractor here.

Moderator: Aaron

p959mc
Volunteer Poster
Posts: 7
Joined: Sat Jun 24, 2017 5:16 pm

YM 276D stalled following filter and oils changes

Postby p959mc » Sat Jan 23, 2021 8:39 pm

I changed fuel, air, hydraulic and oil filters ordered from Hoye and replaced the fluids. I put in Shell Rotella 30 40 oil, started up the tractor and it ran for 30 seconds or so, I removed the hydraulic cap to allow air bubbles to escape since I just added fluid (not sure that is right) and then the tractor stalled quite quickly and would not restart. I live in NY and it is cold, maybe 20 degrees. I originally used an oil filter I got when I purchased the tractor a few years ago and decided to remove that and put on the filter I got from Hoye...Tried starting and it was not even close to starting. Any ideas on what could be going on here?

p959mc
Volunteer Poster
Posts: 7
Joined: Sat Jun 24, 2017 5:16 pm

Re: YM 276D stalled following filter and oils changes

Postby p959mc » Sat Jan 23, 2021 9:19 pm

Hello Aaron,
I just watched the fuel filter change video and I failed to bleed the two nuts to the right of the bowl. I think that may be the issue, will give it a shot tomorrow. I do have a general question on fluids. The first is the oil dip stick down to the right of the hydraulic filter. The stick is not easy to read for a novice. The bottom of the stick has a small section of the stick with XXXs then a few inches up there is a horizontal line. How do I read that? Is midway between the top and bottom of the stick the level needed or should it be at the top of the XXXs? Is there risk in having too much oil? For Hydraulic oil, same questions. One more thing about hydraulic oil, I have had some issues with water somehow getting into the fluid and turns it milky and loses performance. I have changed it twice but it still has a milky look to it on the dip stick, does that make sense or am I just seeing milky fluid where there is none? thanks!


Return to “Tech Support”

Who is online

Users browsing this forum: Google [Bot] and 19 guests