Temp Gauge Issue

Post your questions or problems you are haviing with your Yanmar tractor here.

Moderator: Aaron

AllenH
Volunteer Poster
Posts: 2
Joined: Fri Jun 12, 2020 7:41 pm

Temp Gauge Issue

Postby AllenH » Fri Jun 12, 2020 7:48 pm

I installed a brand new mechanical temp gauge today in my Yanmar 2210. Ran the tractor and checked the temp of coolant with laser temp gun showing 140 deg. New temp gauge never moved off the 100 deg mark. There are no kinks in the line and everything installed easily. Is this suspect a bad unit or am I missing something? Thoughts...

Aaron
Site Administrator
Posts: 3257
Joined: Thu Jul 26, 2007 12:39 pm
Location: Iowa Park, TX

Re: Temp Gauge Issue

Postby Aaron » Sat Jun 13, 2020 7:11 pm

Were were you checking the temperature with the laser thermometer?

See link below for one possibility
https://www.autometer.com/resources/ind ... view/id/11

winston
Volunteer Poster
Posts: 5441
Joined: Mon Feb 01, 2010 7:29 am
Location: North East Texas

Re: Temp Gauge Issue

Postby winston » Sun Jun 14, 2020 5:17 am

I am good at asking stupid questions. Did you install the new sensor and not leave the old one?

AllenH
Volunteer Poster
Posts: 2
Joined: Fri Jun 12, 2020 7:41 pm

Re: Temp Gauge Issue

Postby AllenH » Sun Jun 14, 2020 9:50 pm

Thanks for the responses.

lol :D yes, all brand new. On the Yanmar 2210 swapping from dummy light to an actual mechanical gauge. HTGAUGEKIT which replaces the dummy sensor. Install was quite simple and straight forward.

Gauge never moves after letting idle for some time coolant temp 140 deg at radiator and Top of the prob housing reading about the same +/- 3 deg.

Did some additional testing today. Probe/Gauge definitely bad.

I have requested a replacement gauge.

GBuford4372
Volunteer Poster
Posts: 11
Joined: Tue Jul 07, 2020 4:37 pm

Re: Temp Gauge Issue

Postby GBuford4372 » Sat Jul 11, 2020 4:10 am

Hey Allen, I'm getting ready to install one of those. Where does the probe go? Is there already a place where you screw it in?

winston
Volunteer Poster
Posts: 5441
Joined: Mon Feb 01, 2010 7:29 am
Location: North East Texas

Re: Temp Gauge Issue

Postby winston » Sat Jul 11, 2020 7:09 am

#33 here on the 2210. Those are m16 x 1.5 straight metric threads so be sure that is what you have. Hoyes offers this adapter if needed. https://www.hoyetractor.com/PROD/TGA-M.htm Or the whole 9 yards. https://www.hoyetractor.com/PROD/TGAUGEKIT.htm
Attachments
2020-07-11-080431.jpg
2020-07-11-080431.jpg (149.89 KiB) Viewed 83 times

GBuford4372
Volunteer Poster
Posts: 11
Joined: Tue Jul 07, 2020 4:37 pm

Re: Temp Gauge Issue

Postby GBuford4372 » Sat Jul 11, 2020 6:46 pm

So if I buy the whole kit, that adapter will screw into tractor? That's what I want. No tapping holes for me, and I'm a machinist

winston
Volunteer Poster
Posts: 5441
Joined: Mon Feb 01, 2010 7:29 am
Location: North East Texas

Re: Temp Gauge Issue

Postby winston » Sun Jul 12, 2020 6:07 am

yes


Return to “Tech Support”

Who is online

Users browsing this forum: No registered users and 56 guests